Cooking Hacks Forum
https://www.cooking-hacks.com/forum/

SPO2 problem
https://www.cooking-hacks.com/forum/viewtopic.php?f=39&t=10700
Page 1 of 1

Author:  hhhddd [ Sun Oct 01, 2017 8:45 am ]
Post subject:  SPO2 problem

To whom it may concern

I'm trying to monitor SPO2 values returned by e-Health platform ver 2 from serial monitor in Arduino IDE.
The board is Arduino UNO.

But, the values are completely different.

For example, when the pulse oxymeter display reads "98", serial monitor shows "6" or "0"
consecutively.

I found similar topic posted by TFK in this forum.
In that topic, the team recommended dompiling the sketch using older version of Arduino IDE (Arduino 1.0.1)

I tried this solution but to no avail. :oops:

I also have the following problems.
1. I cannot read ECG-like ECG from ECG sensor of yours. :x
2. the temperature values returned by e-Health sensor is about 3 degrees higher. :x
3. EMG sensor picks up only noise.(No phasic response observed when flexing muscle) :x

But probably, you demand me to post these as separate tipocs.

So, for now, I wait for your response abot SPO2 problem.

Author:  libelium-dev [ Mon Oct 02, 2017 7:47 am ]
Post subject:  Re: SPO2 problem

Hello hhhddd,

We can recommend that you use all versions of the library to identify if it works well with any of them:
https://www.cooking-hacks.com/documentation/tutorials/ehealth-biometric-sensor-platform-arduino-raspberry-pi-medical/#step3_1

Regards

Author:  hhhddd [ Mon Oct 02, 2017 2:36 pm ]
Post subject:  Re: SPO2 problem

You mean...I should try all five versions of libraries?

I'm using the latest version.

Is it possible that some older library is better at handling pulse oxymeter data?

Isn't there any suggestions about which version is most suitable?

best

Author:  libelium-dev [ Tue Oct 03, 2017 8:15 am ]
Post subject:  Re: SPO2 problem

Hello hhhddd,

yes please try every library version, since there are different types of SPO2 and each type works with a different version of the library.

Regards

Author:  hhhddd [ Wed Oct 04, 2017 7:02 pm ]
Post subject:  Re: SPO2 problem

Thank you for your suggestion.

I have two questions.

First, as you can see in other topics i posted, I'm experiencing many problems in your product (and they are driving me mad :evil: )

Do you think that using different version of library solves problems in sensors other than SPO2?

Second, I've already tried two different versions the day before yesterday (I did not take note of which version of library I tested), because your stuffs made same suggestions for SPO2 problem similar to mine in topics a few years ago.

But, at that occasion, compiling of arduino sketch failed. (again, i took no record of error message)
Do you have some ideas about the cause of this failure?

best regards

Author:  libelium-dev [ Thu Oct 05, 2017 8:27 am ]
Post subject:  Re: SPO2 problem

Hello hhhddd,

testing the different versions of the library, in effect, can solve your problem with the SPO2 sensor since there are different versions of this sensor that have been sold over time, and each version requires a different library.

Regards

Author:  hhhddd [ Thu Oct 12, 2017 5:00 am ]
Post subject:  Re: SPO2 problem

Hi everyonne

sorry for bothering you, but i gave up.

Author:  libelium-dev [ Mon Oct 16, 2017 8:46 am ]
Post subject:  Re: SPO2 problem

Hello hhhddd,

we have already answered you here:
viewtopic.php?f=39&t=10719&p=33423&sid=e003995d810c755d04f1a473055b4071#p33423

Regards

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/