Libelium is offering new technical support channels, to contact with de Technical Support team to solve any issue our doubt please contact with your sales agent or visit our contact site



Post a new topicPost a reply Page 1 of 1   [ 5 posts ]
Author Message
 Post subject: Wifi Module Tutorial
PostPosted: Fri Jan 13, 2017 5:36 am 

Joined: Fri Jan 13, 2017 5:23 am
Posts: 9
I try to complete the wifi module tutorial.
I have a arduino uno, a Wifi module and a XBEE shield.
I have a problem at the start : Entering command mode in Arduino.
I think this is because the arduino uno executes a code (As I am using the arduino uno on other matters (open garden)) and does not listen to the serial port.
Does the arduino uno need to be configured a special way to enter in command mode ?
thanks
Antoine


Top
 Profile  
 
 Post subject: Re: Wifi Module Tutorial
PostPosted: Fri Jan 13, 2017 8:27 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hello bryoflor,
to send commands directly to Wifi module through a serial program, you must configure Arduino UNO in gateway mode.
To configure Arduino UNO in gateway mode,
1.- you must remove the micro-controller or load into the micro-controller a bare minimum sketch.
2.- you must configure XBee shield jumpers (or switch) in USB mode.
Regards


Top
 Profile  
 
 Post subject: Re: Wifi Module Tutorial
PostPosted: Sat Jan 14, 2017 6:25 am 

Joined: Fri Jan 13, 2017 5:23 am
Posts: 9
Thanks for this usefull information.

I have been able to connect to the router:

Quote:
CMD
set ip dhcp 1
AOK
<4.41>
set ip protocol 18
AOK
<4.41>
set wlan join 0
AOK
<4.41>
set wlan phrase xxxxxxxxxxxxxxxxxxxxxx
AOK
<4.41>
join chronovideo
<4.41> Auto-Assoc chronovideo chan=11 mode=WEP SCAN OK
Joining chronovideo now..

Associated!
DHCP: Start


but after I think it does not work:
Quote:
show net

SSid=chronovideo
Chan=11
Assoc=OK
Rate=12, 24Mb
Auth=OK
Mode=WEP
DHCP=FAIL
Boot=0
Time=OK
Links=1


and

Quote:
get ip

IF=UP
DHCP=ON
IP=0.0.0.0:2000
NM=0.0.0.0
GW=0.0.0.0
HOST=0.0.0.0:2000
PROTO=TCP,HTTP,
MTU=1524
FLAGS=0x7
TCPMODE=0x0
BACKUP=0.0.0.0


Quote:
set dns name test.libelium.com
AOK
<4.41>
set ip address 0
AOK
<4.41>
set ip remote 80
AOK
<4.41>
set com remote 0
AOK
<4.41>
open
<4.41> ERR:NOIP


What is wrong ?


Top
 Profile  
 
 Post subject: Re: Wifi Module Tutorial
PostPosted: Sat Jan 14, 2017 11:44 am 

Joined: Fri Jan 13, 2017 5:23 am
Posts: 9
I made a test using my smartphone as wifi access, this is working: I have been able to execute the "HTTP complete code" of the tutorial.

Previously, I was using my adsl router as wifi access, I would like to know why the dhcp is not working with the wifi module when it is working prefectly with my PC.

Best Regards
Antoine


Top
 Profile  
 
 Post subject: Re: Wifi Module Tutorial
PostPosted: Mon Jan 16, 2017 9:15 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
hello bryoflor,
this is probably due to your adsl router configuration. Check that no mac filters are enabled or another issues. Try it with other router.
Regards.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 5 posts ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Libelium theme based on 610nm Style by Daniel St. Jules of http://www.gamexe.net


© Libelium Comunicaciones Distribuidas S.L. | Terms of use.