Libelium is offering new technical support channels, to contact with de Technical Support team to solve any issue our doubt please contact with your sales agent or visit our contact site



Post a new topicPost a reply Page 1 of 2   [ 12 posts ]
Go to page 1, 2  Next
Author Message
 Post subject: Multiprotocol Shield and SD card
PostPosted: Sat Feb 25, 2017 12:55 am 

Joined: Mon Jul 25, 2016 12:41 pm
Posts: 6
Hi,

I need to use a SD card to store data before send it using LoRa. When I try to connect SD shield with multi protocol shield it does not allow me to connect. That means SPI pins are not working when the Multiprotocol shield is connected.
Can you give me a solution?

My objective is to save data in a SD card before sending it using LoRA


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Mon Feb 27, 2017 8:45 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi terashmila,

Lora uses SPI pins to work. Maybe that is why when you plug the SD card it doesn't work correctly.

Regards


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Mon Feb 27, 2017 3:06 pm 

Joined: Mon Jul 25, 2016 12:41 pm
Posts: 6
Hi,
Do you have any solution for that can be offered for my question?

I need to use both LoRa and a data storage.

As far as I know we can't use your Multiprotocol shiled with Intel Galileo or any other shiled which has a SD slot on the board.


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Tue Feb 28, 2017 8:37 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hello,
As we say in the Multiprotocol tutorial (2.2 section):
The Multiprotocol Radio Shield includes SPI bus connection in the two sockets, but the voltage levels of the sockets are not the same. The SOCKET0 of the Multiprotocol Radio Shield uses 5V voltage levels and the SOCKET1 uses 3V3 voltage levels.

You can connect the LoRa module to SOCKET1(3V3) and the SD card to SOCKET0(5V) but you need a "5V SD card breakout" and wire to SOCKET0 SPI signals.

Regards


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Tue Feb 28, 2017 2:40 pm 

Joined: Mon Jul 25, 2016 12:41 pm
Posts: 6
Hi,
Can you give me the pin output of the socket 0 ?


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Wed Mar 01, 2017 8:18 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hello terashnila,

The module pinout is:
PIN_01: VCC
PIN_04: MISO
PIN_10: GND
PIN_11: MOSI
PIN_17: CSn
PIN_18: SCLK

Regards


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Mon Mar 06, 2017 2:47 pm 

Joined: Mon Jul 25, 2016 12:41 pm
Posts: 6
Hi,
Thank you it is working.

I bought your RS232 module that can be connected to multiprotocol shield. But I also need to use LoRa + RS232 together. And RS232 needs. How can I connect both? because in your shield we only have one 3.3V pin slots.


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Tue Mar 07, 2017 8:58 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi terashmila,

terashmila wrote:
How can I connect both? because in your shield we only have one 3.3V pin slots.


You can't use with the multiprotocol shield LoRa + RS232, as you say there is only a socket with 3.3v.

Regards


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Thu Sep 28, 2017 8:47 am 

Joined: Fri Aug 25, 2017 1:36 pm
Posts: 4
terashmila wrote:
Hi,
Thank you it is working.

I bought your RS232 module that can be connected to multiprotocol shield. But I also need to use LoRa + RS232 together. And RS232 needs. How can I connect both? because in your shield we only have one 3.3V pin slots.



Hi,
I've the same problem. How did you solve it? Have you connected a 5V SD breakout board to the socket 0 as said by Libelium? Which kind of library did you use then?
Thanks


Top
 Profile  
 
 Post subject: Re: Multiprotocol Shield and SD card
PostPosted: Fri Sep 29, 2017 7:00 am 

Joined: Mon Sep 28, 2009 12:06 pm
Posts: 11366
Hi jakky90,

We have neve rdone it but if you tell us which shield are you using maybe we can help you to connect it.

Regards


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 2   [ 12 posts ]
Go to page 1, 2  Next


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Libelium theme based on 610nm Style by Daniel St. Jules of http://www.gamexe.net


© Libelium Comunicaciones Distribuidas S.L. | Terms of use.